Welcome to iraf.net Monday, December 18 2017 @ 12:57 PM GMT

 Forum Index > Help Desk > General IRAF New Topic Post Reply
 cl script is not running on unix terminal
 06/06/2017 02:50PM (Read 604 times)  

Status: offline

Registered: 01/03/2016
Posts: 13
Dear all,

Does anyone know how to run *.cl scripts on the normal unix terminal??

For eg. I am running a script from the normal unix terminal as:

$ cl < /home/sap/Script/clean_photo.cl

and I am getting an error like:


I also tried with $ cl -o < /home/sap/Script/clean_photo.cl as I read somewhere but again same error.

Can anyone suggest how to do it.

Thanks in advance !!

Profile Email
 08/20/2017 08:41AM  
Regular Member

Status: offline

Registered: 05/01/2014
Posts: 83
CL is meant to be used interactively, not within a script.
You can however "abuse" the feature to load an alternative startup script to run a command -- this is the common way to run scripts:
  • add a line "logout" at the end of your script
  • run it with "cl -f /home/sap/Script/clean_photo.cl"

Profile Email Website
Content generated in: 0.05 seconds
New Topic Post Reply

Normal Topic Normal Topic
Sticky Topic Sticky Topic
Locked Topic Locked Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
Filtered HTML Allowed 
Censored Content 
dog allergies remedies cialis 20 mg chilblain remedies

Privacy Policy
Terms of Use

User Functions